RSS-Feed anzeigen

Nero24.

Sporadische Fehler sind die schönsten Fehler

Bewerten
Ein Bluescreen, verursacht vom Grafiktreiber oder einer seiner Komponenten, muss nicht immer die Grafikkarte als Schuldigen haben. Auch die Grafikkarte wird mit Daten aus dem RAM und vom Prozessor gefüttert und wenn die Müll liefern, gibt's eben nen BSOD. So weit, so klar.

Aber der Fall, mit dem sich kürzlich ein User hilfesuchend an mich wandte, war wirklich "einzigartig" und hat mich 2 Monate (!) lang beschäftigt. Das war so zeitaufwändig, da die Fehler sich nicht "auf Befehl" reproduzieren ließen. Hier bei mir auf der Streckbank traten die Probleme überhaupt nicht auf. Das System bestand sämtliche Tests mit Prime95, Memtest86+, Furmark Stabilitätsloop, etc. ohne Probleme. Beim User jedoch lief das System manchmal 5 Tage ohne Probleme durch, manchmal war nach 5 Minuten Schluss. Der User hatte immer wieder sporadisch BSODs vom Grafiktreiber oder zurückgesetzte Displaytreiber; manchmal beim Spiel, manchmal beim Scrollen im Browser, die meiste Zeit aber eben nicht.

Mit der Zeit hatte ich die komplette Palette durch:

- Eventlog analysiert => außer dem Fehler selbst keine Auffälligkeiten
- Andere Grafikkarte probiert, die in einem anderen System erwiesenermaßen fehlerfrei läuft => Fehler bleiben
- System offen zwecks optimaler Kühlung => Fehler bleiben
- BIOS-Update und alles auf Default => Fehler bleiben
- Stärkeres Netzteil probiert => Fehler bleiben
- Speicher getestet, alles ok => Fehler bleiben
- Speicher trotzdem testweise getauscht, die in einem anderen System erwiesenermaßen fehlerfrei laufen => Fehler bleiben
- Speicher entschärft (Takt/Timings) => Fehler bleiben
- Speicher nur ein Modul => Fehler bleiben
- Frisches Windows 7 x64 statt "vermülltes" Win XP x86 => Fehler bleiben
- Alle möglichen Treiber-Versionen probiert => Fehler bleiben
- System insgesamt entschärft (FSB, Kern, Timings runter, Speedstep off, VCore/VDIMM hoch, etc.) => Fehler bleiben
- andere Steckerleiste probiert => Fehler bleiben
- komplett ohne Peripherie probiert => Fehler bleiben
- Mainboard getauscht => Fehler bleiben

Und ob's was gebracht hat, wurde wie gesagt jeweils immer erst nach einigen Tagen deutlich, da die Fehler derart sporadisch auftraten, dass sie nicht klar zu reproduzieren waren.

Nach zwei Monaten ist mir der Geduldsfaden gerissen und ich habe kurzerhand die gesamte Plattform getauscht, weil's auch dem User natürlich langsam auf den Senkel ging und ich ehrlich gesagt auch nicht mehr wusste, was ich sonst noch hätte probieren können. So ging die alte Plattform mit Intel Core 2 Quad, ASUS P5Q und 2x 2 GB DDR2-800 in Rente und ein AMD FX, ASUS M5A97 Pro und 2x 4 GB DDR3-1866 zogen in sein System ein, das ansonsten unverändert blieb. Seitdem sind die Fehler weg! Obwohl die alten Komponenten für sich jeden meiner Stabilitätstests überstanden haben, war das System in der Praxis nicht stabil. Entweder eine Inkompatibilität oder ein elektrischer Verschleiß irgendeiner Komponente. Was es letztendlich nun genau war, wird ein Geheimnis bleiben müssen Aber manchmal hilft eben nur noch die Holzhammer-Methode, wenn man mit Logik und feingliedrigem Sezieren nicht mehr weiter kommt.

"Wunderbar" ist in so einem Fall natürlich, dass man all die Stunden, die man dafür ver(sch)wendet hat, einem Privat-Mann gar nicht in Rechnung stellen kann. Das fällt dann unter "persönliches Engagement"...

Was war denn Eure verrückteste Fehlersuche?

Kommentare

Seite 1 von 2 12 LetzteLetzte
  1. Avatar von Onkel Homie
    Ähnliche Geschichte mit allen möglichen Tests und nahezu purer Verzweiflung.

    Der Fehler lag letztendlich daran Microsoft&Logitech Tastatur+Maus mit einem bestimmten MSI Board verwenden zu wollen. Egal ob teure G15 oder billige 15€ Tastatur. Wenn auf dem Gerät und MS oder Logitech Schriftzug war ging nix. Wir hatten halt verschiedene in der Werkstatt und der olle PC stand immer mal an nem anderen Platz. damit wurde letztendlich alles durchgetestet was gerade rumlag.

    Irgendwer kam damals auf die Idee einfach mal was von den NoName Eingabegeräten anzuschließen und siehe da, alles lief bestens.

    So was hatte ich zuvor nie erlebt und danach auch nie wieder.
  2. Avatar von Schwarzmetaller
    Auf Arbeit einen Rechner gebaut....damals einen der ersten P4 mit 64Bit-Erweiterung....ein ziemliches High-Endsystem der >1000€-Klasse.
    Zusammengebaut und dann ging es ans Installieren von Windows....auf den Knopf gedrückt, Rechner geht an->alle Lüfter laufen, aber wilde Piepsorgie, die keinem Symptom zuordenbar war, und kein Bild.
    Alle Kabel geprüft, und wieder probiert->selbes Verhalten.
    Andere Grafikkarte probiert->selbes Verhalten.
    Also Mainboard aus dem Gehäuse geschraubt und "freifliegend" probiert->selbes Verhalten.
    Dann habe ich gesehen, daß ein Katalog quer auf der Tastatur lag und ~die Hälfte aller Tasten permanent gedrückt waren.^^
  3. Avatar von [3DC]Payne
    Ich würde darauf tippen, dass die CPU einen weg hatte...

    Aber die CPU bei so einem alten System zu tauschen, macht nicht wirklich viel Sinn, so dass es unterm Strich besser ist, die 'Holzhammermethode' zu nehmen...

    Hier muss ich sagen, dass ich wohl relativ früh den Gedanken in den Kopf des Users, für den ich den PC prüfen sollte, gesetzt hätte, dass der Rechner geupdatet werden müsse, da sich der Fehler nicht rekonstruieren lässt.

    Mit Pech ists auch einfach nur irgendein blöder korrodierter Kontakt oder aber eine Feder, die nicht mehr stark genug ist (im LGA Sockel oder in 'nem Slot)...
  4. Avatar von Blutengel_6_6_6
    hallo

    ich hatte auch ein intel sys hier mit den core2 und selber fehlerbeschreibung wich habe jedoch von xp auf vista und win7 hatt ales nichts gebracht
    auch die sachen getauscht und so weiter jetz liegt das ding keller rum

    ich glaube langsam das es die cpu schrot fehlerhaft ist
  5. Avatar von SnakeByte0815
    Tachchen

    Ich hatte ein ähnliches Problem wie Schwarzmetaller ...

    Ein Kumpel rief mich an, ob ich mal vorbeikommen könnte und mal nach dem Rechner seine Mutter schauen würde.

    Als erstes ist mir aufgefallen, das das noch ein alter Sockel A Rechner mit einem Athlon Xp 2400+ war ... 512 MB DDR1 Ram .. Grafikkarte kann ich dir gar nicht sagen ... ich glaube das war eine von den Anfangstagen der FX 5xxx Serie ...
    Naja alles in allem habe ich schon die Augen gerollt, weil es sich eigentlich nicht mehr wirklich Lohnt an solchen alten Systemen nach etwas zu machen ...
    Man will aber seinen Horizont erweitern und nun habe ich an die Fehlersuche gemacht:

    Rechner an ... keine 3 Sekunden später ging das Piepkonzert los ... Naja, kein BIOS-Kompendium dabei, also wusste ich die Codes nicht zu deuten ... Also 0 Methode

    Alles Geräte ab(außer Maus und Tastatur"weil schnurlos set" & zwecks BIOS unn so ^^) >> selbe in Grün ... Ram umgesteckt(durch alle 4 Bänke) >>> selbe in Grün ... Kabel alle geprüft >>> immernoch ... Kontake überprüft >>> nicht gebraucht ... BIOS RESET >>> immernoch das selbe ... Maus &Tastatur ab und siehe da, es ging weiter bis er mir meldete das kein System geladen werden kann ... Das grenze den Fehler ein ... Platte dran und zack für der Rechner hoch ... Also mit Schalter wieder aus ... Maus & Tastatur drann >>> PIEPKONZERT ...

    Jetzt dachte ich das Set war im Arsch, aber weit gefehlt .. durch blöden Zufall habe ich gesehen, dass die Leuchte vom Tastaturempfänger blinke ...

    Da hat sich doch tatsächlich eine Taste in der Tastatur verklemmt oder verklebt ... und das war der grund weswegen der Rechner nicht wollte ... Welche Taste das war kann ich leider nicht sagen ... Die haben das Set weggeschmissen und sich ein neues Geholt ... Seit dem habe ich nie wieder was von denen gehört ...

    Manchmal steckt der Teufel doch im Detail ^^
  6. Avatar von OwnTheRacetrack
    Hallo,

    manchmal liegt es vielleicht auch gar nicht am PC. Vor ca. 4 Jahren hatte eine Arbeitskollegin auch sporadische Abstürze (Windows XP). Mal mit BSOD's mal ohne. Also geschraubt, geprüft, gewechselt... - Problem nicht behoben!

    Auffällig war, dass die Abstürze sehr häufig kurz nach einem Druckjob passierten. Druckertreiber Auch durch andere Versionen ersetzt - das Problem blieb. Wieder Ratlosigkeit.

    Dann habe ich noch mal unter den Schreibtisch geschaut. Das einzige was ich sah, war ein Papierkorb und der Trafo ihres Druckers.

    Dann erinnerte ich mich das Thema Induktivspannung und auftretende Magnetfelder.

    Und siehe da - Trafo weg - Problem weg.

    Ich vermute, wenn der Drucker durch einen Druckjob aus dem Stand-by geholt wurde und der Trafo richtig Leistung brachte, die Magnetfelder so stark wurden und die Halbleiter verwirrten. Anders kann ich es mir nicht erklären.

    Also, munter bleiben!
  7. Avatar von Loader009
    Da füge ich auch mal ne kleine Erfahrung hinzu.

    Hatte ein System aufgebaut, aber aufgrund der zu lauten Geräusche von der OnBoard Soundkarte, habe ich das Mainboard eingeschickt...
    Habe nie ein repariertes zurück erhalten, aber das Board gefiel mir.
    Nunja, sowas werde ich wohl nie wieder tun, aber ich habe mir das selbe Board bei ebay ersteigert <- ein fataler Fehler.

    Das Board "lief", aber mit Krücken. (ein DFI LanParty DK 790FXB-M2RSH)
    Sobald eine Grafikkarte in den ersten PCIe Slot eingesetzt wurde, lief irgendwas gründlich schief.
    Die Zeit innerhalb des PCs lief in vielfacher Geschwindigkeit, ein kurzer Druck auf eine Taste wurde mehr als 10 mal angenommen, eine Passworteingabe war unmöglich.
    Gelegentlich lief das System auch mal stabil, die Grafikkarte lief im besagten Slot statt der erwarteten x16 nur mit x4.
    Ein Slot-wechsel half nur begrenzt, das BIOS war nur sporadisch erreichbar und das belegen einiger bestimmter FAN-Anschlüsse resultierte im selben Problem.

    Einen Defekt vom optischen her konnte man nicht entdecken.
    Meine Vermutung ist, dass sich die Northbridge (auf dem Board, PCIe Anbindung) irgendwann mal überhitzt hatte und somit ein paar "Leitungen" sich querstellten.
    Für mich bedeutet das, dass man keine Mainboards bei ebay kaufen sollte, die gut fürs Übertakten sind, auch wenn man nicht Übertakten möchte.
  8. Avatar von Opteron
    Ich hatte (habe?) auch so ein Problem. Bei mir wars wohl ein Kombifehler aus RAM+Grafikkarte.

    Habe jetzt nach Speichertausch und höher drehenden GraKa-Lüfter keine Probleme mehr, nur 2 Abstürze als ich vergaß den Graka-Lüfter einzustellen.

    Allgemein haben solche vertrackten Probleme wohl mehrere Ursachen. Nur das Symptom ist blöderweise wohl gleich -> Absturz. In Neros Fall muss es schlussendlich ja das Mainboard gewesen sein, eventuell war die Leitpaste auf der Northbridge zu alt (wichtig, da dort früher ja noch der Speicherkontroller war) - oder halt ein echter Alterungsdefekt irgendwo anders.
    Edit: Sehe gerade erst, dass auch das Mainboard getauscht wurde. Da würde mich dann interessieren, welcher RAM verwendet wurde. Der getestete, gute, oder wieder der Originalspeicher? Oder auch die Grafikkarte .. da gibts zZt ja gehäufte Meldungen, dass einige ATIs komisch laufen. Interessant nun, dass das bei mir ein Intel System war, bei Nero auch, und es nun im AMD System funktioniert ... eventuell gibts da kleinste Timing-Unterschiede mit Intel-Chipsätzen, bzw. schlechtere Kompatibilitätstests auf Intel allgemein, seit AMD ATi übernommen hat? Wäre mal interessant, aber da man das Problem sehr schlecht nachstellen kann, wohl auch sehr schlecht zu recherchieren.
  9. Avatar von Nero24.
    @Opteron:
    Original-Grafikkarte war eine NVIDIA GeForce GTX 550, gegengetestet wurde mit einer ATI Radeon HD 4650.
    Original-RAMs waren 4x Mushkin DDR2-800, gegengetestet wurde mit 2x Samsung DDR2-800
    Original-Board war ein ASUS P5Q, gegengetestet wurde mit einem ASUS P5A.

    Wenn ich mir das im Nachhinein alles so überlege, denke ich fast, dass Blutengel_6_6_6 recht hat: es muss die CPU gewesen sein! Das ist die einzig relevante Komponente, die wir nicht getauscht hatten vor dem kompletten Plattform-Tausch.

    Allerdings wäre das in meinen 20 Jahren PC-Schrauberdarsein die erste CPU, die ohne Fremdeinwirkung (abgebrochenes Die bei Kühlermontage ohne Heatspreader oder Extrem-OC) einfach so kaputt gegangen wäre. Zudem mag man an einen CPU-Defekt fast nicht denken ob der extrem sporadisch auftretenden Fehler. Bei einer defekten CPU müsste das System praktisch sofort abschmieren, wenn die defekte Einheit bemüht wird.
  10. Avatar von JKuehl
    Die schönste Geschichte war immer noch folgende:

    Mein Rechner lief damals mit einem X2 3800+ unter Wasser - wochenlanges 24/7 Rendering, Gaming, etc. etc. kein Problem.

    Mein bester Freund der immer Pech mit Hardware jeglicher Art hat kam zu Besuch da sein Rechner wieder mal defekt war um schnell was bei mir auszudrucken.

    Bei betreten des Arbeitszimmers spürte mein Rechner der wochenlang stabil lief auf vier Meter Abstand die Präsenz meines Kumpels und kapitulierte mit einem Blue Screen.
Seite 1 von 2 12 LetzteLetzte

Trackbacks

Single Sign On provided by vBSSO