Ergebnis 1 bis 7 von 7
  1. Beitrag #1
    User-News Von 0laf ist offline
    Hinweis: Diese "User-News" wurde nicht von der Planet 3DNow! Redaktion veröffentlicht, sondern vom oben genannten Leser, der persönlich für den hier veröffentlichten Inhalt haftet.

    Ubuntu 11.04: Probleme mit erhöhtem Energieverbrauch

    Nach Installation der kürzlich erschienenen Ubuntu 11.04 Version werden einige Nutzer durch einen höheren Energieverbrauch und öfter anspringende Lüfter geplagt.
    Mittlerweile wurde in den Release-Notes von Ubuntu 11.04 in der Kategorie "Known Issues, Linux Kernel" folgender Punkt hinzugefügt:
    10-30% increase in power consumption.
    Besonders Benutzer eines Notebooks dürften darüber nur wenig erfreut sein.
    Ein Bugreport wurde ebenfalls angelegt. Dieser ist unter folgendem Link zu finden: bugs.lauchpad.

    Phoronix hat bereits in der letzten Woche damit begonnen, die Ubuntu 11.04 Beta2 Version ausführlich zu testen und konnte dabei die beschriebene Regression aufdecken. Bis zum jetzigen Zeitpunkt sind 3 Artikel zu dem Thema auf Phoronix veröffentlicht worden:



    Der Autor Michael Larabel äußert die Vermutung, dass im Linux Kernel ab Version 2.6.38 ein Fehler besteht, der den Energieverbrauch negativ beinflusst. Im Artikel "The Tests Showing Ubuntu 11.04 On A Power Consumption Binge" wird die Leistungsaufnahme auf ingesamt 4 Notebooks (IBM ThinkPad R52, Lenovo Thinkpad T60,Lenovo ThinkPad T61, Samsung NC10) von Ubuntu 8.04 bis 11.04 verglichen. Michael Larabel betont, dass der erhöhte Energiebedarf unabhängig von der verbauten Grafikkarte , also Ati/Nvidia/Intel, und dem folglich verwendeten Treiber auftrat.

    Allerdings scheint das Samsung NC10 mit Intel-Grafikeinheit von dem Fehler nicht betroffen zu sein. Nur bei Auslastung der Grafikeinheit ist eine höhere Leistungsaufnahme vorhanden, jedoch einhergehend mit einer besseren FPS-Rate.
    Bei dem ThinkPad T61 mit Nvidia-Grafikeinheit ist eine gesteigerte Leistungsaufnahme bemerkbar; ebenso beim ThinkPad R52 und Thinkpad T60, die jeweils mit Ati-Grafikchips bestückt sind. Das könnte jedoch auch zumindest teilweise mit den erst seit kurzem standardmäßig eingesetzten Grafikkartentreibern Nouveau und Radeon zusammenhängen.

    Hoffentlich ist bald die genaue Ursache bekannt. Phoronix versucht mittlerweile mit einem automatisiertem Verfahren, bei dem die vorherige Kernelversion Stück für Stück gepatched und anschließend getestet wird, den Fehler genauer einzugrenzen (mehr zu dem Verfahren: hier).

    Eigene Messungen
    Weil davon ausgegangen wird, dass im Kernel 2.6.38 das Problem steckt, bin ich auf die Idee gekommen, einmal unter Debian 6.0 (Squeeze) den besagten Kernel aus dem Testing-Zweig zu kompilieren und zu installieren. Anschließend konnte ich dann den Linux Kernel 2.6.38 mit dem bei Debian Squeeze standardmäßig installiertem Kernel 2.6.32 vergleichen ohne sonst etwas am System zu verändern. Die Leistungsaufnahme wurde an einem anderen Recher mit einem Voltcraft VC940 über die serielle Schnittstelle aufgezeichnet.

    Testsystem 1
    Prozessor: AMD Athlon64 X2 Dual Core Processor 5000+(undervolted)
    Mainboard: DFI LP DK 790GX
    Grafik: Nvidia Geforce 7600GS
    Desktop: Openbox
    Grafiktreiber: nvidia 270.41.06


    Die CPU taktet bei beiden Kernel-Versionen ordnungsgemäß im Leerlauf herunter. Die Spannungswerte werden ebenfalls abgesenkt. Bei der Nvidia-Grafikkarte ist der PowerMizer aktiv.

    Unter Last läuft die CPU dann mit 2600MHz, beide Kernel-Versionen verhalten sich gleich:

    Im Leerlauf ändert sich die Leistungsaufnahme nur kaum merklich: Kernel 2.6.32 im Schnitt 45.061W, Kernel 2.6.38 im Schnitt 44.594W. Bei nur 200 Sekunden Aufzeichnungsdauer lässt sich nicht sagen, welcher Kernel tatsächlich hungriger ist. Edit: eine zweite Messung über 1000 Sekunden ergab: 43.860W für Kernel 2.6.32 und 44.163W für Kernel 2.6.38. Im Hintergrund anlaufende Prozesse sorgen immer wieder für ein wenig Variation.

    Edit:
    Unter Last ist auf diesem System keine Veränderung feststellbar. Die Grafik zeigt die während 4 aufeinanderfolgender openssl-Benchmarkläufe gemessene Leistungsaufnahme (Durchschnitt: Kernel 2.6.32: 60.23W, Kernel 2.6.38: 60.21W):

    Das Ergebnis des openssl-Benchmarks:


    Testsystem 2
    Prozessor: Intel Core2Duo T5200
    Mainboard: Fujitsu V3405 Mainboard
    Grafik: Intel GMA 950
    Desktop: Openbox
    Grafiktreiber: intel 2.13


    Im Leerlauf besteht kein nennenswerter Unterschied: bei Kernel 2.6.32 im Schnitt 6.412W, bei Kernel 2.6.38 im Schnitt 6.289W.




    Fazit
    Was lässt sich daraus schließen? Es sind definitv nicht alle Installationen mit Linux Kernel 2.6.38 betroffen. Es wäre also möglich, dass ein Modul des Kernels, das den Fehler enthält, nicht auf allen Systemen geladen wird (z.B. für bestimmte Wireless-Lan Modelle), oder das die Kombination mit einem bestimmten Grafikeinheit/Treiber/Xorg-Version zu dem höheren Verbrauch führt.



    Verbrauchswerte unter Last muss ich leider nachreichen, da ist beim Aufzeichnen der Messwerte etwas schief gelaufen, ich hab nur leere Log-Dateien
    Als nächstes möchte ich auch noch probieren ,ob sich die Sache ändert, wenn ich bei System1 den Nouveau-Treiber anstelle des Nvidia closed-source Treibers verwende.
    Geändert von 0laf (02.05.2011 um 23:24 Uhr) Grund: neue Messwerte eingefügt

  2. Die folgenden 7 Benutzer sagen Danke zu 0laf für diesen nützlichen Beitrag:

    BLJ (02.05.2011), camo (02.05.2011), Cashran (03.05.2011), Lynxeye (09.05.2011), Oi!Olli (03.05.2011), ONH (03.05.2011), SPawner (01.05.2011)

  3. Beitrag #2
    Fleet Captain
    Special
    Fleet Captain

    Registriert seit
    19.08.2010
    Beiträge
    256
    Danke
    22
    Gedankt 1 Mal für 1 Thema
    Als ich den Stromverbrauch zu mal getestet habe, habe ich Windows 7 Ubuntu 10.4 gegenübergestellt und festgestellt, das Ubuntu die bessere Akkulaufzeit hatte.
    Es war teilweise bis zu einer Stunde besser.
    Da kann ich die verübergehende Einschränkung verkraften

  4. Beitrag #3
    Themenstarter
    Lt. Commander
    Lt. Commander
    • Mein System
      Desktopsystem
      Prozessor: AMD Athlon Thunderbird 1.4Ghz (Stand: 21.5.2009)
      Mainboard: MSI K7T266 Pro
      Kühlung: Spire Falconrock
      Arbeitsspeicher: 512MB
      Grafikkarte: Leadtek 6800LE 128MB
      Display: Samsung SyncMster 226BW
      Festplatte(n): Seagate 160GB
      Soundkarte: Soundblaster Audigy2 + Beyerdynamic DTX800
      Betriebssystem(e): Debian etch
      Browser: Konqueror

    Registriert seit
    30.10.2007
    Beiträge
    129
    Danke
    27
    Gedankt 106 Mal für 14 Themen

    Als ich den Stromverbrauch zu mal getestet habe, habe ich Windows 7 Ubuntu 10.4 gegenübergestellt und festgestellt, das Ubuntu die bessere Akkulaufzeit hatte.
    Es war teilweise bis zu einer Stunde besser.
    So etwas liest man eher selten Was für ein Notebook ist es denn?

    kleines Update, von System1 habe ich nun noch die Leistungsaufnahme unter Last ermittelt. Keine Veränderung

    Anschließend wollte ich dann das Gleiche mit dem Nouveau Treiber wiederholen. Allerdings läuft die Treiberversion nicht auf Kernel 2.6.38. Grund dafür scheint dies hier zu sein: (click)
    Ich müsste also einen neuere Version von libdrm aufspielen und dann einen aktuelleren Nouveau-Treiber installieren. Dierser benötigt dann allerdings eine höhere Xserver-Xorg Version.
    Das klingt zumindest nach Aufwand

    Für mehr war leider keine Zeit Ich weiß auch nicht ob es gerade sinnvoll ist, noch mehr Zeit darin zu investieren, es scheint nicht gerade viele zu interessieren

  5. Beitrag #4
    Redaktion
    Redaktion
    Avatar von Onkel_Dithmeyer
    • Mein System
      Notebook
      Modell: Thinkpad X230t
      Desktopsystem
      Prozessor: AMD A10-6700 (ohne Turbo)
      Mainboard: Biostar HiFi A88W
      Kühlung: Xigmatek Archilles S1284C
      Arbeitsspeicher: 2x4 GEIL+ 2x4 GSkill
      Grafikkarte: HD Radeon HD 7870 GHz
      Display: 16:10 27"
      SSD(s): Crucial M4 128
      Festplatte(n): 3TB HDD (Seagate)
      Optische Laufwerke: BDRom-Combo (Samsung)
      Soundkarte: Onboard
      Gehäuse: Cubitec Magic Cube
      Netzteil: Seasonic G-360 80PLUS GOLD SS-360GP
      Betriebssystem(e): Ubuntu 13.04 mit Gnome 3.8; Win 7 64 SP1
      Browser: Firefox Version 94715468

    Registriert seit
    22.04.2008
    Ort
    Ripze
    Beiträge
    6.288
    Danke
    107
    Gedankt 1.706 Mal für 166 Themen
    Blog-Einträge
    8
    Zitat Zitat von 0laf Beitrag anzeigen
    So etwas liest man eher selten Was für ein Notebook ist es denn?
    Kann ich aber auch bestätigen, mein Lenovo Edge 11 schafft mit Ubuntu 10.04 ~30 Minuten länger als mit Win7 64. Dafür funktionieren Standby und Ruhezustand nur sporadisch.

  6. Beitrag #5
    Themenstarter
    Lt. Commander
    Lt. Commander
    • Mein System
      Desktopsystem
      Prozessor: AMD Athlon Thunderbird 1.4Ghz (Stand: 21.5.2009)
      Mainboard: MSI K7T266 Pro
      Kühlung: Spire Falconrock
      Arbeitsspeicher: 512MB
      Grafikkarte: Leadtek 6800LE 128MB
      Display: Samsung SyncMster 226BW
      Festplatte(n): Seagate 160GB
      Soundkarte: Soundblaster Audigy2 + Beyerdynamic DTX800
      Betriebssystem(e): Debian etch
      Browser: Konqueror

    Registriert seit
    30.10.2007
    Beiträge
    129
    Danke
    27
    Gedankt 106 Mal für 14 Themen
    Kann ich aber auch bestätigen, mein Lenovo Edge 11 schafft mit Ubuntu 10.04 ~30 Minuten länger als mit Win7 64.
    Ok, ich will nichts gesagt haben Dann bin ich was das betrifft nicht mehr ganz am aktuellen Stand

    Dafür funktionieren Standby und Ruhezustand nur sporadisch.
    Hast du mal diesen Patch ausprobiert? https://bugs.launchpad.net/linux/+bug/702434

  7. Beitrag #6
    Redaktion
    Redaktion
    Avatar von Onkel_Dithmeyer
    • Mein System
      Notebook
      Modell: Thinkpad X230t
      Desktopsystem
      Prozessor: AMD A10-6700 (ohne Turbo)
      Mainboard: Biostar HiFi A88W
      Kühlung: Xigmatek Archilles S1284C
      Arbeitsspeicher: 2x4 GEIL+ 2x4 GSkill
      Grafikkarte: HD Radeon HD 7870 GHz
      Display: 16:10 27"
      SSD(s): Crucial M4 128
      Festplatte(n): 3TB HDD (Seagate)
      Optische Laufwerke: BDRom-Combo (Samsung)
      Soundkarte: Onboard
      Gehäuse: Cubitec Magic Cube
      Netzteil: Seasonic G-360 80PLUS GOLD SS-360GP
      Betriebssystem(e): Ubuntu 13.04 mit Gnome 3.8; Win 7 64 SP1
      Browser: Firefox Version 94715468

    Registriert seit
    22.04.2008
    Ort
    Ripze
    Beiträge
    6.288
    Danke
    107
    Gedankt 1.706 Mal für 166 Themen
    Blog-Einträge
    8
    Zitat Zitat von 0laf Beitrag anzeigen
    Hast du mal diesen Patch ausprobiert? https://bugs.launchpad.net/linux/+bug/702434
    Nein, aber im Moment kann ich das auch nicht, weil ich von Arbeitswegen gezwungen bin Windows 7 einzusetzen. Aber das auch nur noch bis Mitte des Monats. Danach werde ich wohl mal Ubuntu 11.04 auf dem Gerät installieren, auch wenn ich auf meinem Desktop mit dem OS gerade einige Probleme habe

  8. Beitrag #7
    Cadet

    Registriert seit
    08.05.2011
    Beiträge
    3
    Danke
    0
    Gedankt 0 Mal für 0 Themen
    Hallo

    Habe den Leistungsverbrauch unter Win 7 HP 64Bit und Ubuntu 11.04 auf meinem Desktop-PC (AMD Phenom II X6 1055T, NVIDIA GeForce GTX460 1GB) verglichen. Beide Systeme verbrauchen im Idl-Modus ca. 91-92 Watt.

    Leider startet Ubuntu nicht fehlerfrei. Nachdem der Boot-Loader angezeigt wird und ich Ubuntu auswähle bleibt der PC erst einmal hängen. Nach Betätigung der Enter-Taste gehts dann weiter und Ubuntu wird von meiner SSD-Festplatte gestartet.

    Auf meiner 64GB SSD habe ich Windows 7 und Ubuntu 11.04 komplett neu installiert. Die Festplatte habe ich wie folgt partitioniert:
    Win7 HP 64Bit auf 35GB-Partition
    Ubuntu 11.04 auf 20GB-Partition
    Upuntu SWAP 1GB

    Gruß Rolf

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •  
Single Sign On provided by vBSSO